Статьи » Обзоры
Добавить статью

Таблица для расчета стоимости товаров и услуг для бизнеса

2021-10-20 в 23:45

Представляю нашим читателям и тем кто зашел сюда через "Я загуглю ща" универсальную систему расчет общей стоимости работ, товаров, услуг и т.д. Она может быть полезной бизнесу, реализующий различные виды товаров и оказывающий широкий перечень работ в "одном чеке".

Ее можно использовать для расчет услуг электрика с расчетом всех чистовых материалов типа розеток, выключателей и т.д. Могут ее так же использовать и монтажники слаботочных сетей, мастера по сантехнике, да и вообще этот список профессий думаю достаточно широк. 

Она построена и работает в Google таблицах. Все достаточно просто, что не скажешь с первого взгляда. Для ее работы достаточно составить правильный прайс-лист на товары и услуги. Он должен находиться на соседнем к примеру листе, чтобы в случае необходимости его можно было быстро поправить.

В моем варианте, я делал данную систему расчета именно для услуг электрика, расчет стоимости работ и материалов. Как видно, лист с прайсом называется Цены на услуги. Название здесь очень важно, ведь в формулах он фигурирует во всех действующих строках.

Тут по факту нужно просто перечислить все услуги и работы которые вы оказываете и выполняете, обязательно нужно указать единицу измерения (м.п., шт, м, км, см и т.д.) а так же указать стоимость за данную единицу. В основном листе расчетов вы выберите данную услугу, укажите ее количество, и данное значение будет перемножено на стоимость. В итоге получим общую стоимость по конкретной услуге.

Чтобы все эти данные появились, необходимо ввести специальные формулы в каждом столбце. Название услуги в строке мы не вносим вручную, а выбираем в выпадающем списке из тех, что мы внесли в листе прайса.

Делается это в во вкладке Данные - Проверка данных, где указываем диапазон ячеек с соседнего листа. Тут достаточно теперь просто начать вводить первые буквы, и таблица сама будет предлагать имеющиеся варианты наименований.

Далее необходимо в этой же строке услуги вывести ее единицу измерения и стоимость за единицу. Для ячейки единицы измерения это осуществляется при помощи формулы:

=ЕСЛИОШИБКА(ИНДЕКС('Цены на услуги'!B:B;ПОИСКПОЗ(A2;'Цены на услуги'!A:A;0));)

Для ячейки стоимости:

=ЕСЛИОШИБКА(ИНДЕКС('Цены на услуги'!C:C;ПОИСКПОЗ(A2;'Цены на услуги'!A:A;0));)

В ячейке Итоговое количество указываем что мастер при замерах реально рассчитал (а может и фактически после выполнения работ). Тут просто значение. В строке Сумма просто умножается количество и стоимость в данной строке.

=ЕСЛИОШИБКА(C2*D2;)

И таким образом мы вписываем в основном листе расчета все оказываемые услуги или даже уже оказанные, ведь может быть и предварительный расчет, а потом еще и окончательный, то есть фактический. Для этого можно создавать несколько Листов расчета. Данные все равно будут браться из Листа цен на услуги.

Для удобства, в столбцах содержащие цены можно установить Денежный формат, чтобы указывался значок валюты.

Список услуг оказалось может быть очень большим, и чтобы было удобно видеть окончательную стоимость без скрола до конца, я сделал еще несколько ячеек для вывода итоговых данных. Итоговую стоимость в моем примере я рассчитывал в USD. Тоесть прайс по сути имел привязку к доллару. Но клиенту сообщалась стоимость в белорусских рублях. Для этого я применил парсинг актуального курса валют с сайта Национального банка Беларуси.

С товаром смысл будет тот же. Просто вместе или вместо услуг в прайсе, вписываем товар и производим расчет.

Если будут вопросы задавайте, может даже смогу ответить. Предложения и улучшения так же очень интересны.

Не пропустите обновления! Подписывайтесь на нашу страницу в Instagram.
Так же у нас есть Telegram канал.

Вам понравился наш проект? Поделитесь с друзьями!

Просмотров: 167. Оценка статьи: 4.9 из 5. Уже оценило 12 читателей

Об авторе - Администратор

More by Администратор

Вам может быть это интересно

Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]